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Preliminary Documentation

The information in this document is subject to change without notice.

Kowa Company, Ltd assumes no responsibility for any errorsin this document or the software described in this
document.

Kowa Company, Ltd also assumes no responsibility for any troubles including data damage caused by hardware
accident, disk crash, windows system disorder, or wrong operation.

Use the UPS(Uninterruptible Power Supplies), and backup data.

The software described in this document is furnished under license. The software may only be used by one user at
atime.

Copyright 2000,2001,2002 Kowa Company, Ltd.
All rights reserved.

1.Introduction

KowaVK-2 isaprofessiona digital imaging system for ophthalmology and optometry. VK-2 offers the features
you need to acquire, analyze, and store your patient image data. And because the tools you use the most are
available right on the desktop, you'll get superior results quickly and easily.

This high-resolution system supports images captured by afundus camera and dlit lamp. VK-2 also makes it
possible to view images captured by other video equipment.

The VK-2 User Guide provides information about the VK-2 operations and functions. It is designed to be used as
aquick reference guide. This manual assumes you are proficient in the use of afundus camera and/or dlit lamp.
Y ou should also be familiar with how to use the mouse, menus and dialog boxes, and how to open and closefiles.

This user’s manual describes the details to operate. But to capture and check the captured image, you
only use 3 buttons [Input 1D, Prev, View] (see 3.Basic Operation). That isall. It issimpleto use.



2.Starting and Exiting VK-2

1. Turnonyour PC to automatically launch VK-2. The Start-Up dialog window appears. Then the VK-2
application windows are displayed.

2. Toclosethe application, click the Exit button.

3. Double-click theicon “VK-2" on the desktop to start the application.

Sart Up Dialog

/ Disk Free Space

VK-2 Application Windows

I mage frame window

Image process tool bar —
Video input select toolbar ——,

Command toolbar
The VK-2 work areaincludes: an image frame window containing an image and a menu bar at the top of the
window, and various toolbars available to provide easy access to the tools used for viewing and editing images.

Don't put the toolbar or dialog window on Image frame window, when capturing image. (The image will
be captured with thetoolbar or the dialog window)

ThisMark on the dialog window means theimageis not captured correctly,

when capturing an image.

(Only for Nonmyd Alfa-D connection:
* \When Nonmyd Alfa-D is power- on before VK2 application starts, press the button of joystick trigger on
Nonmyd Alfa-D in order to initialize the camera as the message shows.




3.Basic Operation.

FUNDUS CAMERA
1.From the video input select toolbar,
Click on button #.

2.From the command toolbar,
Click the Input Data button.

3.The Patient Dialog window appears
Typein Patient ID(see Input Data section) and Click Ok.
The systemis ready to capture an image.

4.Capturing images using the Joystick on the Fundus
Camera, The captured image appears in the window.
VK-2 automatically saves the image.

Additional frequently used functions:
5. Change to maximum window size.

6.View the previous image.

7.Print out the image

SLIT LAMP
1. From the video input select toolbar,
Click on button #.

2. From the command toolbar,
Click the Input Data button.

3. The Patient Dialog window appears
Typein Patient ID and Click Ok.
The systemis ready to capture an image.

4.The window displays alive video image.
Push the foot-switch to freeze the image.
Push the foot-switch a second time to release and
view thelive image.

5. To save an image, Click the SAVE button on
the command toolbar while the live image is frozen.

Additional frequently used functions:
7. View the previous image.

8.Print out the image




4.0peration of Command Toolbar Function

4-1.Command Toolbar
Shown hereis the Command Toolbar. Details on the operation of each function is shown on the
following pages.

<«— |nput Data: Open the dialog window to input Patient ID, Name, Sex, Birth-date
and Doctor.

<«— Search ID: Open the dialog window to search a patient’simages by Patient ID
number(see Input Data section).

<«— ldList: Search the Patient ID list.

<+— Previouslmage: View the previousimage

<«— Next Image: View the next image.

<«— Multiple Image: Switch to 1,2,4,6,9,16 multiple images on display.

<«—— Frame Size: Switch the image viewing size from standard to maximum size.

<— |mage Process: Show the Image Processing toolbar.

<+— Edit Data: Open the dialog box to edit patient information.

<«—— Capture: Freezethelive video image.

<«— Savelmage: Save the captured image.

<— Print Out: Print out the displayed image directly.

<+— Exit: Exit VK-2 application.



4-2. Input Data

4-2-1.<ID TYPE>

1.Click the INPUT DATA button to enter patient information.
The patient information dialog window for | D appears.

2.Input the Patient 1D number by clicking the figures on the display or by typing on the keyboard.
Patient ID may consist of acombination of numbers, letters and symbols. For example: 108-1.
3.Typein patient name.
Note: Patient name may be changed at a later time using the Edit Data button.
4. Enter other information, if you need.

Doctor and Diagnosis name are automatically saved in a pull down list for easy access.

4-2-2. <NAME TY PE>
1.Click the INPUT DATA button to enter patient information.
The patient information dialog window for Name appears.

2.Input the Patient Name by typing on the keyboard.
3.Enter other information, if you need.
When you don’'t enter Patient ID, ID is assigned automatically.

Note: You can choose either type, <ID MODE> or <NAME TYPE>. See[4-27. Choose Input Data

5



4-3.Search 1D
4-3-1. <ID TYPE>
1. Click the SEARCH ID button to search images from the database.

2. Enter the Patient ID and click Ok. A list of sessions associated with the Patient ID is displayed.

4-3-2. <NAME TY PE>
1. Click the SEARCH I D button to search images from the database.

2. Enter the Patient Name or Patient ID, and click OKk.
(You just input either one)

- Click Advanced Search to jump to Id List Command window (see4-9.Advanced Search Id List).
- When image data does not exist, the below message appears.

Back Again: Show Search ID dialog again and Retry Search ID
Jump to Advanced Search: Advanced Search Id List appears

Note: If your VK-2 system has a magnetic card reader or bar code reader, you may use these
devices to input patient data only while the Input Data and Search Id windows are open.

Note: You can choose either type, <ID MODE> or <NAME TYPE>. See[4-27. Choose |nput Data Type]
6



4-4. Previous Image and Next Image
1. Click the PREV button to display the image previous to the current image.
2. Click the NEXT button to display the image following the current image.

Currentimage —»
Total number

of images for T
the patient

Patient nane —» <«— Captured date and time
Patientld —>

Enlarged view of the window bar. /

Image Info Patient 1D 100 [[Marme  Tam Kamit o

To hide patient text infor mation:
Do one of the following:

» Choose [View]>[Show Text Info] from the menu, Click on the check mark to deselect.
This change appliesto current session only. System will return to default setting at the
next start-up.

Or
¢ Choose [View]>[ Setting Text Info]>[Show Date, Time] ,[Show ID, Name],

Click on the check mark to deselect.
This method changes the default setting.



4-5.Multiple Image

Select the MULTI button to change the display from one image to up to16 images from a patient’ s file.

To change the display from oneimage to sixteen images.

1. Click the MULTI button.

2. Click PREV or NEXT button to view other images in thefile.

3. Double-click on any image to return the display to asingle image.

Todisplay two images side-by-side from a patient’ sfile:

1. From the sixteen multiple image display, select two images of interest by clicking on each. The word “ Select

# appears on each image.

2. Click the Multi button. The selected images are shown in the display window.

3. Click the Multi button to return to the sixteen-image display, or double-click on an image to view asingle

image.

Todisplay four imagesin the window:

1. From the sixteen multiple image, select four images of interest by clicking on each. The word “ Select #’
appears on each image.

2. Repeat steps 2 and 3 above.

Todisplay six or sixteen images:

1. Inthe menu, choose [Setting] > [Multi-Select Image Number] > [4] [6] [9] or [16].

2. Repeat the steps as shown above, except select six or nine images to display.

View the previous or
Following pages.

<Chekand select images

2,4,6,0r 9 images

Back to the 16 multiple images

<

\/
Doubleclick to 1 image




4-5-1. 36 multiple image
Checked the mark in “multiple-display 36 image”,
the number of the multiple image change from 16 to 36.

In Menu [ Setting]>>[Option Setting]

/

Clicking [NEGA] button in Image Process Bar,
Multiple image is changed to B/W image.

4-5-2. Make the quality of thumbnail image better
Checked the mark in “Use original image in thumbnail”,
the thumbnail image uses original image.

(Usually thumbnail image uses thumbnail files those are the reference files to show the image quickly though the
image quality is not good)



4-6.Frame Size

The frame size button allows you to increase or reduce your view of the image.

To change the frame size, click on the frame size button.

For an image from adigital camera, the view changes from fit-to-screen to actual size.
To scroll the image, do one of the following:

‘Use the scroll bars to view portions of the image that do not fit in the screen.

Or

-Position the pointer over the image. Then hold down the left mouse button as you move the pointer. The image

moves with the pointer ‘_@

4-7.Image Process
Click on the Image Process button to display the image processing bar as shown.

«
Non-Check .;S'Horizontal

You can choose horizontal or vertical type of imaging processing var.
Choose [ Setting]>>[Other Setting]>>[V ertical type image controlbar]

v

Check->Vertical

When you change this setting, need to exit and re-start VK-2 application.

Refer to the Image Processing parts section for further details. -> [5.1mage Processing]

10



4-8.Edit Data
The Edit Data button allows you to view and change patient information.
Click Edit Datato display Patient Information dialog window.

Enter information in the
dialog box

 Changes to name, sex
and birth-date will
appear on al theimages
for that patient ID.

» Changesto eye
direction, and comment
will only appear on
current image.

When you only change Diagnosis or Doctor, the bel ow message appears.

v

Note: “ Original ID” entered in the Patient Dialog before capturing cannot be changed per manently.

11



4-9.Advanced Search List

4-9-1. Advanced Search ID List

The ID list allows you to perform a search for patient records by using patient 1D and name, or by date. The
Database List dialog window displays alist of all patient records sorted by 1D number.

To open the database:

1. Click the Open List button from the Command toolbar. Database List dialog appears.

2. Or click on the Advanced Search button in the Search ID dialog window (see Search ID section).
3. Scroll through the list to locate a specific patient ID.

Todisplay alist of records associated with a specific patient 1D:
1. Enter patient ID or name (or only beginning characters) in dialog box.
With Using ‘*’, you can see the candidate of the list (ex. *Barker > Bob Barker)
Click Start Search. A list of patients that match the search entered in the ID or Name field are displayed in the
list window and sorted by the ID or Name.
3. Click on any field to select a patient record. A list of al records associated with the patient ID isdisplayed in
the lower window. The patient records are grouped by date and archived disk number.  If the patient has

multiple data sets with the same date and disk number, they will be grouped together in one line in the lower
window.

2.

4. Double Click on any field in the lower window to select a specific patient record to view. The last image of
the record is displayed.

5. Click on the Multi button to display multiple images on the screen.
Todisplay alist of all patient sessions performed on the current day:
1. Click Today button. A list of all sessions taken on the current date is displayed.

[ID TYPE]
Search from Patient |d and Name
(Only beginning characters)

Reset to complete patient 1D list

Display list of sessions taken on the current day

« Enter Patient Id or name to display
A list of images.

* Click Start Search button,
* Or click on Today button
To show all images captured today

lick to show the details
Sorted by date and
Archived disk #.

Inorder by ID # Open image from archived media

[See 4-20.0pen from Archived Medid]

Note: You can choose either type, <ID MODE> or <NAME TYPE>. See[4-27. Choose Input Data Type]

12



4-9-1. Advanced Search Name List

[Name TY PE] Reset to complete patient ID list
Search from Patient |d and Name
(Only beginning characters) Display list of sessions taken on the current day

« Enter Patient Id or name to display
A list of images.
* Click Start Search button,
Or click on Today button
: 1 show all images captured today

Click to show the details
Sorted by date and
Archived disk #.

Double click to display images

In order by Name # \ Open image from archived media
[See 4-20.0pen from Archived Media]
Click [DATE] »
Recommend inputting less than one or two weeks
quick response.

4-9-3. Display Multiple Patient Image
Check the different patient image in one frame.

Right
Mouse
Button

2.
1.Select some patients by Right Clicking.
The selected patients are shown on the lower window.
2.Click Multi-View button.
Y ou can see the different patient image in one frame.

13



4-9-4. Diagnoses in Database List

In menu, [Setting]>>[Option Setting]

If checked mark in “ Show al diagnosesin Database List”, all diagnoses you edited would be shown in the
database list, though the opening list speed becomes slow.

Not checked, the common diagnosis edited in all imagesis shown.

14



4-10.Capture Image
The Capture button can be used instead of the foot-switch to freeze and resume the live video.

Capture button is “out” when alive patient video is displayed in the capture window.

The button is “pushed” in when the capture window is displaying an image from
memory or afrozen live image.

4-11.Save Image

Click Save to save a captured image to memory when using the Capture I mage button as described above. (Note:
images are automatically saved in the Fundus Capture mode.)

4-12.Print Out
Print out image or images shown in the capture window to the specified printer.

» Print out 1 image

y Or print out 2,4,6,9 or 16 multiple images on asingle page

15



Operation of Menu Functions
The following functions are located from a pull-down list in the menu bar.

4-13.Select Print Out

The Select Print Out command allows you to print a selected set of images from the multiple image display.
Important: the printer settings must be set to “ bi-directional support” and the “ time-out” to maximum time
allowed.

1. Choose from the menu [Setting] > [Set Right Click Mode] > [Select Print].

2. From the multiple image display, select the images to be printed by right clicking on each.

3. Click Print Out button from Command toolbar.

4-14.Delete Images

To delete a singleimage:

1. Display theimage to be deleted.

2. Choose [File]>[Delete Image] from the menu. A warning message appears.
3. Click Ok.

Delete one image.
Click OK and the image will be deleted.

A

To delete several images or a singleimage from a multiple display:
1. From the multiple display, right click on imagesto be deleted.
2. Choose [File]>[Delete Image] from menu.

Delete several images at the same time.

16



4-15.Delete Image of the same ID

To delete a series of image of the same ID at atime, click the Open List button from the Command toolbar.

Select the record to delete on the left click. (With pushing “Ctrl” key on the left click, you can select several
records)

After select records, push “Delete” key. The message appears and input the Password “vk” to delete.

Delete key

Delete the selected ID data at atime

4-16.Save Edited I mage

To save an image after editing, choose [File] > [Save Edited Image]. A yellow marker is added to the upper left
corner of the edited image. The date and time of the original image is also added.

q

Y ellow marker signifies that the image has been edited.

17



4-17.Copy Image to Other Media
1.Copy to the floppy disk.
View the image to copy, and Choose [Fil€]>[Copy Image to Floppy].
The image datais copied to afloppy disk in aJpeg file format of: Id number+Serial number.jpg

2.Copy Selected Images to Folder
1. Chose from the menu [Setting]>[ Set Right Click Mode]>[Select Copy].

In Menu [Setting]>>[Option Setting]
Check the mark in “Export BMPfile”, and the image is
exported as BMP format

2.Use the Multi button to view multiple images (see Multiple Image section). Select the images to
copy by aright-click of the mouse. “COPY” appears on the image.

3.Choose from the menu [File]> [Copy Selected images to Folder].
Copy dialog box appears.

4.Select the folder to copy and Click OK.

The selected images will be copied to the folder.

4-18.0Open Previous Komit | mage

VK-2 supports files saved under previous versions of KOMIT software.

Insert the previous version CD into the appropriate drive before you open the image.

1. Choose [File]>[Open KOMIT Image]. Open dialog window lists the files in the current folder.
2. Select the drive and folder where isimage is located. Select the image you want to open.

4-19.0pen Previous Komit Database

VK-2 supports the database saved using a previous version of Komit software.

Insert the previous version CD into the appropriate drive before you begin your search.
1. Choose[Filg] > [Open KOMIT Database].

2. Select the drive where the database is located. select the database you want to open.

18



4-20.0pen from Archived Media
VK-2 supports to read the image data from the Archived Media that other VK-2 system captured.
Insert the Archived Mediainto the appropriate drive before you begin your search.
1. Choose[Fil€] > [Open from Archived Medid],
Or Click [Open Archived Media] on Advanced Search List.
2. Double Click the Patient ID on thelist to read and display the image.

4-21.Copy to Clipboard

Y ou can copy an image to the Clipboard in the Windows operating system. The image becomes available to paste
into other applications.

4-22.Input Text

The Input Text command lets you to annotate your images. To input text on an image:
1. Choose [Edit] > [Input Text].

2. Click in the image where you want the type to appear. The type dialog box appears.
3. Choose [File]>[Save Edited Image] to save the text information on the image.

Input Text with line
After drawing line, insert text on an image.
1.Cose [Edit] > [Input Text with line
2.Draw line, moving mouse while holding down left button
3.After drawing line, the type dialog box appears, and type text.
3.Choose [File]>[Save Edited Image] to save the text information on the image.

4-23.Check Disk Space
To view the amount of disk space available on your hard drive, choose from the menu [View ]> [Show Space of
Disk]. The dialog box appears.

Capacity of Disk Available disk space Percent empty

19



4-24.Show Squar e (2 images)

When displaying two images side by side, the Show Square function lets you crop the right and left side from
each image to provide a better view for comparison.

1. Display two images of interest in the window (see Multiple Image section).

2. Choose [View] > [Show Square (2 images)]. Check mark appears to show it has been selected.

Original view(images are square)

Show rectanqular selected

4-25. Compar e two images
Another method to compare two images with using Multi- method.
1.Display the first image and modify in the image processing.
2.Choose [Edit]>[Copy to Image Memory1] to copy
to the temporary memory.

3.Display the second image and modify in the image processing.
4.Choose [Edit]>[Show Image Memoryl & Thig]
Two images appear on the display.

5.Double click on the image to show back to the second image.

4-26. Prohibit No ID Images
* Choose [ Setting]>[Other Setting]>[Prohibit No Patient 1D]
from the menu, Click on the check mark to select or deselect.
Checking mark on-> invalid to capture image
without Patient ID
No mark > Available to capture image without Patient 1D

20



4-27. Choose I nput Data Type
» Choose [ Setting]>[ Option Setting] from menu.

Check mark on [List> Name Modg], Name Type.
List Name orders list.

Take off mark on[List> Name Modg], ID Type.
Patient ID orderslist.

4-28. Set display mode after searching

 Choose [ Setting]>[Option Setting] from V

Check mark on [Search->Multiple View]
After searching data, 16 multiple images are shown from the first one.

Take off mark on [Search->Multiple View].
After searching data, the last image is shown.

4-29. Footer and Header for Printing
When printing, print out the information
with images.

» Choose [ Setting]>[Header & Footer]
from menu.

Check mark [Print out Header & Footer], and

printing style is changed. \

Take off mark on [Print out Header & Footer]

21



4-30.Send Image by E-Mail
Y ou can send selected image by E-Mail[Outlook Express] quickly and easily.
To use this function, need to set up Outlook Express beforehand (Refer to the Windows Manual).

1. Usethe Multi button to view multiple images (see Multiple Image section).
2. Choose [File]>[Send Selected Image be <E-Mail>].

3. The message “ Select Images’ appears.

4. Select the images to copy by aright-click of the mouse. “MAIL” appears on the image.

\

5.Choose [File]>[Send Selected Image be <E-Mail>], and Outlook Express starts up.

In Subject and Attach item,
The data are set automatically.

ITIf the image is Delta Format, the image is changed to Jpeg Format in order
to open image by standard PC viewer.

File “inf.txt” including patient information of attached image filesis automatically attached.

d] button to send the images.
22
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4-31.Drag image

Drag one image on the multiple 16 image mode and move mouse while holding down left button, and drop to
other application, folder , Floppy disk, or other removable media

Y ou can copy one image to other media easily.

M Drag and copy to Floppy disk

If the image forr / changed to Jpeg format, so drag fun'ction

speed is alittle delay to transfer image.

4-32.Print out at White Mask

When printing out, change black mask image to white color for fundus mask image.
Choose [ Setting]>[ Printing Header& Footer].

Check <Mask of background from black to white>

This white mask process sometimes fails, when image quality is bad, too dark, or when black level is floating.
When some character information is on the black mask, this process does not work correctly.

23



4-33.Show the datelist

Y ou can export the patient list of the specified date as text file.

Choose [Database] >[ Show print list each day].

Select the date you want to get, and click OK, the date list including patient information would be shown as text
file.

So you can print out, and if the array is disorder, you can save thisfile to the floppy and carry to other PC
installed Excel application, and at the Excel application, open this file as delimiters—TAB.

4-34.Stereo assist

Y ou can get the stereo image easily following the message of stereo assist.

Thisfunction is good to check the depth of the optical nerve head at 20 degree angle of fundus camera as the
stereo image.

Choose [Capture] >>[Stereo Assist].

Set alignment and adjust focus. Change the setting of fundus camerato 20 degree.

Move the joystick of the fundus camera dlightly to the left as the assist image is shown, and push joystick button
to capture image. If the captured image is good, click [Y es] to save the image. If theimage is not good, click [NO]
and try again. After capturing one image, the next assist view to get right direction image would appear.

After getting two image of left and right direction, the stereo viewer application “Para’ would appear.
Refer to the explanation of stereo view. (See “5.25 Stereo Viewer”)

24



4-35.Link to Perimeter

As one of the options of our Imaging system, you install the Perimeter application “FT8” AP-5000C, and you can
startup and call the Perimeter application from VK2 application.

In Menu [File]>>[Startup AP5000C] is active after installing application “FT8” AP-5000C.

From FT8 application, each results after measuring could be saved into VK 2E database.

25



5.Image Processing
VK-2 offersavariety of toolsfor helping you analyze and edit your images. Y ou access these tools

though the Image Processing toolbar or through the menu in the capture window.

Image Processing Toolbar

Most of the tools you need are located on the Image Processing toolbar for easy access.
To displav the toolbar, click on the Image Process button in the Command toolbar.

Each button on this toolbar will modify the displayed image only. The original patient image will not be modified.

5-1.Sharpen Image

The Sharp tool improves the clarity and definition of the edges of the image.

Click the sharp button to sharpen the image.

You can change the level of sharpening applied to an image by choosing from the menu
bar [Image Proc] > [Sharp] > [Light | Medium | Strong] .

5-2.Gamma Process
Change the Gamma curve of the image.
Y ou can set the gamma curve as you like, selecting the curve and move on left click of mouse.

<Clear Point>:Clear al set point

<End Point>: after [Clear Point],

and right click on the chart
\ to set new points.
After setting new all points,
click [End Point]
to show anew graph.
<Save Point>: Save the current curve setting.

<Load Point>: Load the saved curve setting.

In menu there are three fixed types of Gamma curve preparing from the menu.
+ - Expand the black level
- —~>Expand the white level
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5-3.Enhance lmage

Use the Enhance button to better visualize subtle gray level changesin the image.

1. Click Enhanc. The Enhance window appears.

2. Do one of the following:

o Slide the bar to set the window levels. Click Ok.

e Click on adesired point in the image to automatically adjust the tonal range based on that point.

:>S|idethebar

4\

Click on apoint in the image

Other options for enhancement are available in the menu. Choose [Image Proc] > [Enhance] > [Enhance2]
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5-4.Contrast
When working with an image that is dark or has poor contrast click the Contst button to
automatically adjust the contrast.

5-5.Brightness
To change the brightness of an image:
1. Click onthe Bright button. The Bright dialog box appears.
2. Move the mouse over the image to display the gray level at that point in the image.
3. Do one of the following:
¢ Adjust the level by clicking on the Dark and Brt buttonsin the dialog window.

e Click the RGB button in the Bright dialog window to display the RGB dliders. Use the sliders to

independently adjust the red, green, and blue levels of the image.

Shows the gray level at mouse position

/

<«— Adjust thelevel of brightness

Display the RGB bar

—__ Adjustthe RGB levels

5-6.Analysis of RGB color

You can view the individual color components in the image with the Red, Green, and Blue buttons.
o Click the Red button to view only the red color component in the image.

o Similarly, click the Green or Blue button to individually display the respective color components.

5-7.Negative Image
Click on the Nega button to view a negative of the image.

5-8.Flip Image

To flip the image in the vertical or horizontal direction:

1. Click on U/D to flip theimage vertically (top to bottom) along the horizontal axis.
2. Click on L/R to flip the image horizontally (Ieft to right) along the vertical axis.

5-9.Zoom Image
The Zoom tool magnifies the image view.

Click the Zoom button. Cursor will changeto a®.
2. Click on point of interest in the image to magnify to twice the size.
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5-10.Measure Length

To measure the relative length between two points:

1. Click the Length button. The Length dialog box appears.

2. Click on one endpoint of a segment of interest, and move mouse while holding down left button.
The length of the segment is displayed in the dialog window in the Length box. To measure another segment,
click on two more points.

3. Click the End button in the dialog box. The value of the last segment measured is automatically
displayed on the image.

If checked the mark in <Disk Off>,
The circle as reference disk size is not shown

[Setting]>>[Other Setting]>>[Set Length]
Y ou can change the basic length of Disk.
Default disk sizeis 1.6mm

Y ou can measure the length betw
But cannot record the value of length on the image. (To record the value, select one image)
Show two images, and Click the Length button.

5-11.Measure Cupdisk Rate

There are two methods to measure the cupdisk rate.

Oneisto use area, the other is to use length.

Y ou can set this method in menu [ Setting]>[Option Setting]
Check mark “Use length when measuring cup disk” -> Length method
Not check -> Area method
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5-11-1.Area method

To measure the cup-to-disk ratio:

1. Click the Cup tool. The Cup Areadialog box appears

2. Move the mouse around the cup area, clicking 12 points to define the edge. The area of the cup is displayed.
Maximum points are 12 points. By clicking [End] button, you can select less than 12.

3. Move the mouse around the disk area, again clicking 12 points to define the edge. The area of the disk is
displayed. The cup-to-disk ratio is displayed in the dialog window.

4. Click the Ok button to finish. Theratio is automatically displayed on the image.

5-11-2.L ength method

To measure the cup-to-disk ratio:

1. Click the Cup tool. The Cup Areadialog box appears

Click on one endpoint of a segment of interest, and move mouse while holding down left button.
Click on another endpoint, and move mouse while holding down left button.

4. Click the Ok button to finish. Theratio is automatically displayed on the image.
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5-12.Measure Angle

To measure an angle in aregion of interest:

1. Click onthe Angle button. The Angle dialog window appears.

2. Define an angle by clicking on three points in the image. The angle value appearsin the dialog box.
3. Click the End button when finished. The value is automatically displayed on the image.

5-13.Loop

Y ou can use the Loop tool automatically view apatient’s images in succession.

1. Display asingleimage from a patient’ sfile.

2. Click the Loop button. The movieis displayed.

3. Click ontheimage or push any key on the keyboard to stop.

Y ou may change the speed of the movie. From the menu choose [Setting] > [Other Setting] > [ Speed of
Slideshow] > [Fast | Slow].

5-14.Undo Image
Back to the previous image.
In menu [Setting]>>[Option Setting..]

- Set the UNDO count
Default is 3.

If Physical Memory oOf PC is over 512Mbyte,
Set the value more than 3

5-15.0rigin Image
Restore and view the original image before image processing.
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5-16.Reference(Template) Image

Y ou can compare a patient image with a reference image you' ve saved. VK-2 allows you to store up to
64(multiply 8 by 8 items) reference images.

Todisplay thereference image for comparison:

1. Display patient image.

2. Click Temp button. Reference image is displayed beside patient image.

3. Doubleclick on patient image to close reference image.

Double click here
to change the reference image.

Double click here
to closereferenceimage. >

Double click here
to change the reference item. ——— —

Note: Change the content in
‘VK-2 Temp’ on the desktop to show

thetext under the number e/
Click this button to compar

the image with the reference.

To add a new referenceimage:
Display the image you want to use as a reference. From the menu choose [ Capture] > [Register
Reference]>[Reference *].

To delete areferenceimage:
Select the image to delete with aright click of the mouse, and choose [File] > [Delete Image].
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I mage Processing Menu Functions

5-17.Merge and Subtract

Y ou can merge two images together, and then subtract one image from another using the merge function. VK-2
will align and merge two images based on reference points you' ve chosen.

1. Display two image and choose from the menu Image Proc > Merge.

2. Click two points on the left image. (Which can easily be remembered).

3. Click near the same corresponding points on the right image. VK-2 locates the point in the right image that
most closely matches the point in the left image. The merged images are displayed.

4. Click Subtraction button to subtract between two images.
5. Allowsyou to change the rate of each image with the slide bar.

Note: With certain images, VK-2 may not be able to find a corresponding point in the designated region in the
second image. In this case, the merge function cannot perform properly, and the resulting merged images will be
of poor quality. You may select the exact points on which to align the images by repeating the above steps, except
hold down Adjust button or Manual Position button.

v

Move, Rotate, Magnify manually
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5-18.Noise Reduction

The Median or Average filter allows you to reduce the noise in the image.

Y ou can apply a Median filter by choosing from the menu [Image Proc] > [Noise Reduction] > [Median]

Y ou can also apply an Average filter by choosing from the menu [Image Proc] > [Noise Reduction] > [Average]

5-19.PDT Function

Y ou can select and draw the part of PDT.

1.Display oneimage and choose PDT function from menu [Image Proc]>[PDT]
2.PDT dialog appears.

3.Draw the line on the image while holding left button of mouse.

4.If failed to draw, try to draw again
5.Click Calculate button, and circleis drawn.
6.Click OK button, and new outer circle outside of about 1000um of the circle is drawn.
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I mage Processing Mouse Functions

5-20. Enhance part of theimage
Doubleclick in an area of interest on the image.
A section of the image is enhanced.

5-21.Analisys of gray level

Y ou can view the change in gray level along a horizontal line across the image.

Gray levels range from black to white, with black being the top values on the graph.

Totemporarily display the gray level:

1. Right-click and hold on a selected point in the image to display the gray level along a horizontal line, enabling
you to see the changein levels across the image.

2. Release the mouse to remove.

To permanently display thegray level:
Repeat step one above, but left-click on mouse before releasing.

5-22.Magnifying Glass

Left-Click and Move mouse on the image.

The Magnifying Glass with auto-bright processing is shown.
Release the mouse to remove.

To permanently display Magnifying Glass:
Right-click on mouse before releasing.
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5-23.Auto Enhance (M ultiple Display)
After showing multiple images on display, Push <F12> key.
The image would be adjusted to proper contrast.

S

The message “ Auto-Enhance ON [slow to view]” appears on the taskbar.
When this auto-enhance function is on, the processing speed would become slow.
Before capturing image, Push <F12> key again to set back to default.

5-24.Each Enhance Function

After showing multiple images(2,4,6,9 multiple mode) on the display, select the image to be modified at right
click on theimage. The selected image is surrounded by the blue rectangle.

Click image processing toolbar, you can modify the selected image.

Thisfunction is available at Sharpen, Gamma, Enhance, Contrast, Brightness, R-G-B free, Nega, Up-Down, and
Right-L eft process.
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Special Functions

5-25.Stereo Viewer

The stereo viewer button would appear only when the patient data has the stereo image.
(How to get the stereo image, refer to “4-34.Stereo assist”)

Click stereo button, and the stereo viewer “3D Para’ would appear.

1) Click one point on the almost the center of the optical nerve head.

2) Click [VIEW] button to change to the next image,
3) Click one point on the same position of the previous image.
4) Click [STEREOQ] button to show the stereo image.
When the positioning is not good, click [CLEAR POSITION] and try to set the point again.
When click [ZOOM STEREQ] button, the image size gets big.
Push the arrow key such as‘ < * in the keyboard to change the position of the center.
Push the ‘PageUp’ or ‘PageDown’ key to magnify or reduce the image.
Click [BRIGHT] button to make the image brighter.

Recommended position of the click point
Optic nerve head picture

(About positioning between each image:

In menu [View]>>[Setting]>>[Invalidate Auto Position], get rid of the check mark [Invalidate Auto Position], the
positioning process is half automatic to shift the best position between each image after pointing roughly.

Usually need to set the exact points between each image.)
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5) Click [3D Model], you can seethe virtual 3D model.

While holding right-click button of the mouse, move the mouse, and you can revolute the model of the image
asyou like.

While holding left-click button of the mouse, move the mouse, you can move the position of the image.

Addition:
When you use the stereo assist function (refer to 4.34 Stereo assist) of VK 2E, the shift direction of the
stereo information is saved automatically.
Y ou can input this shift direction manually as follows.
1) Show the stereo image on the display and click [Edit Data] button.
2) Inthe ‘Patient Information’ box, there is the item “ Comment”.
3) Type “stereo_|/" or “stereo_r/” in the comment, and click [APPLY]
4) After inputting both “stereo |/ and “stereo_r/” in each stereo image.
5) Read the patient data again by [Search ID].
6) Y ou would confirm the button [STEREOQ] at |eft side.
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5-26.Red FreeFilter Processing

When you use Kowa fundus camera with Digital Camera(KD211C, KD630, D2H), ‘Red Free Filter” is
inserted, the image would be changed from green color image to B/W image automatically with
software red free reorganization algorism .

Bl -

5-27.Electronic 30 degree image capturing (available for VX-10)
KD211C, KD630 supports 30° degree function for capturing macular

/'

When selected 30 °, the original image is saved in 30 degree size.

In order to show this 30°-50° button, check the mark in menu [ Setting]>>[Input& Trigger Setting]>>[Permit
Setting] ,and select [ Setting]>>[Input& Trigger Setting]>>[Edit Setting]

Check the mark <Show 30 deg{ VX-10)>
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6.View Database

The List of Patient ID window allows you to access patient data cards and images.
Note!!'1:Only English character isavailableto read and write in this part.

6-1.List of Patient ID

Open Database Window:

From the menu choose [ Database |> [Switch to Detail Database].

The List of Patient ID window appears.

Toreturn to the Capture window:
Click Back to CAPTURE Mode button in the List of
Patient ID window. The Capture window appears.
Note: If you displayed a Patient ID card or a patient image
while viewing the database, the capture window
will display an image of that patient

To sort the database:
LliIntheList of Patient ID window, right-click
on Last Visit Field
2.Click on the Sort Descending or Sort Ascending button.

Click hereto open the search dialog
Click here to open [All Lists of Patient]
Click here to open [Patient Data Card]
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6-2.Patient Data Card
The Patient Data Card window provides patient information and comments, and alist of all the images associated
with that patient ID. Y ou can review and compare images to monitor changes.

To open a patient data card:
From the List of Patient ID window, click on apatient ID to view that patient’s data card.

Toview an image:

1. In the patient data card, click in the date field of a specific image to see a preview of that image.
2. Double-click on the preview image to display it in the capture window.

To view athumbnail of all the patient’simages:

Click on the Thumbnail button to display thumbnailsin the Multi display window.
Note: Images can only be loaded from the hard disk or CD-R. They cannot be loaded from the CD-ROM.

NS

Double click

-
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6-3. Listsof All Patients
Click on the All button in the List of Patient ID window to open the All Lists of Patients window.

/I:i nd or Replace the information

6-4.FILTER
Click on the Filter button in the List of Patient ID window to open the search dialog.
Input the information to extract the data.

\ 4




7.0pening and Saving Images from other Devices

7-1. Opening and Saving other Image File Formats
VK-2 alows you to import any JPEG, BMP, or TIFF image into a patient file.
1.Click the ‘VK_Scan’ application on the desktop to start. Scan dialog box appears.

2.Click [OPEN FILE]

g

3.Select Image File to open.
Full color format of JPEG ,BMP ,TIFF file can be opened.

/

4.Click [INPUT DATA] to open input data dialog. Input Patient ID.

5.Click Save to save theimage. Y ou can now view and edit the image in VK-2. When viewing theimage in the
Capture window, a green mark is added at the left edge of the image to indicate that the image was imported from

another application.

The green mark from Open File is added at the |eft edge of the image.
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7-2.Scanning an Image into VK-2

VK-2 support 3" party scanners with Twain drivers.
LIngtall Image Scanner software.

2.Click Scan application on the desktop to start.
3.Click Setting and select Twain source.

4.Click [SCAN]

Select the resolution and set the mode “ Full Color” image.

5.After the image is scanned, the image is shown in the frame window.

6.Click [INPUT DATA] to open input data dialog. Enter Patient ID.

7. Click [SAVE] to save theimage. Y ou can now view and edit theimage in VK-2.

The green mark from Scanner File is added at the |eft edge of the image



7-3.Dropoing and saving Image into VK-2
VK-2 allows you to import any JPEG, BMP, or TIFF image into a patient file with using Drop function
at the same time.

Select some images imported from other application or folder, and move mouse while holding down left
button, and drop on the Scan application.

After dropping image, the message “ Do you want to save the dropped image as ID=*** " gppears. If
select “NO”, after inputting new Patient Name and 1D, the image would be saved.
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8.Arhciving Data

8-1.Archiving to aremovable media
Y ou can make a back up of your patient records on the hard disk to a CD-R, CD-RW, DVD-RAM.

8-2.Check the settings (CD-R, RW)
Open the Settings dialog window and check the Archive Drive number. Make sure the Archive Drive letter shown
is the same as the CD-R to be used for archive. Look in the My Computer window to see the drive letters for al

drives on your system.

CD-R drive
[E] \

Look in the Taskbar in the lower right corner of your screen
to verify the DirectCD software is running.
The DirectCD icon is shown.

(Note:When starting-up VK-2, the program to check archiving will work. It will take several seconds.
And when need to archive, the message box to archive the data to CD-R appears.)

When you use the CD-RW media (not CD-R), you can archive the data at any time
(after a medical examination every day) as data backup.
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8-3. Format Blank CD-R
<roxio Drag-to-Disc>

1. Insert blank CD-R mediainto CD-R drive.

/

Click on the menu icon P

Drop down list appear

Select format di

Type the disk no on the volume label

Aait until format is complete
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<DirectCD>

1. Insert blank CD-R mediainto CD-R drive.
2. Select Direct CD icon.

The DirectCD software will appear.

Follow the instructions to format a CD.

o
-~
AN



8-4. Start Archive

From the menu choose [Archive] > [Start Archive] and click OK. Depending on the amount of datato be
archived, CD-R may have remaining space that can be used on afuture archive.

The timing to start Archive depends on the media.

CD-RW, DVD-RAM: You can archive data at any time (after a medical examination every day) as data backup.

CD-R: When the message appears at the time when data exceed the capacity of CD-R media, you need to
archive data only once.

N\

l (Press [End] key, you can stop archiving)

CD-RisFull
Need to change CD-R

Archive Finished. (Spaceis available on the disk for future archive)

The VK-2 software uses the disk number to identify each disk. M ake a note of the disk number shown in
the in Information window, so that you may writethe number on the CD-R after it is g ected.
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8-5.Eject CD-R
<roxio Drag-to-Disc>

/ 1. Click onthe Eject icon

When the CD-R disk becomes full, check the

checkbox that say “ Protect disk so that it cannot
be written to again”

Important: Perform this step only if the CD isfull

2. Click on the Eject button

3. Writethe disk no on the CD-R media

NO * k%
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<Direct CD>

Eject CD_R or click the DirectCD icon in taskbar and follow the instructions. Using a soft tip marker, write the
disk number onto the CD-R.

/.

_— —
Next Next

When the CD-R disk becomes full, check “Close
toread...” checkbox. This changes the CD to
that it can be read on most standard CD-ROM
drives.

Important: Perform this step only on a full CD-R
disk. Oncethediskis“ Organized” it cannot be
written to again.

Finish

OK

Disk will be Ejected.

Writethe DISK NO on the CD-R medial

O

NQO ***
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Structure of this Archive method

data. Enter the percentage of archived data that you would like to delete from the hard disk. Y ou can aso initiate
Note: Thiswill not delete data that has not been archived to CD-R.

Asyou save patient information, the space on your hard drive becomes full. After the information is archived to a
the delete process manually by choosing from the menu [Archive] > [Delete Archived Data f/Hard Disk].

CD-R, you can delete the archived information to make disk space available for new patient data.
When the available disk space is less than 15%, a dialog window will appear prompting you to delete archived

8-6.Delete Archived Image from Hard disk

Archived Mediaff;

\
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(Cf. Delete Image and Database at atime)

“8-6.Delete Archived Image from Hard disk” is the delete way after archiving to the backup media.

But the system does not archived drive, and user does not have to stock old data.
When datadisk is full, you can delete old data from the first to the middle point, and maintain the empty area. But
the deleted data would be diminishing permanently and never come back.

Choose [Database]>[Del ete Database& Image Data] >Del ete Database& | mage]
Pass two messages “YES’ and input password “vk”.
Select rate(%) to delete from old data. The deleted data never come back.

Be careful!l
Thedeleted data never restore.

Note: Do not use this method, Usually use “ 8-6.Delete Archived Image from Hard disk” method
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8-7.Read image data from Archived Media

When you perform a search for patient information that is not on the hard disk - or islocated on both the hard disk
and on archived media - a dialog window appears requesting where to access the information. Select one of the
following options to indicate where you want to access image data.

The Data Exizts in Another Archived Mediall
Read fram Only Hard Disk. [not Bead from Archived tMedia) |

Read from Archived Media and Hard Disk i

Restore the Archived Data back to Hard Disk |

Archived Disk MO, !3

» Read from Only Hard Disk [not Read from Archived Media]
Select this option if you want to display information from the hard disk only. If none of the image data is actually
located on the hard disk, an image will not be displayed in the Capture window.

» Read from Archived Media and Hard Disk

Select this option to read information from both the hard disk and from archive media. Insert the archived media
asindicated in the message window into the appropriate drive. The Capture window will display images from the
hard disk and from the archive media. If VK-2 does not find the requested information on the archived media, the
systemwill use images fromthe hard disk only.

» Restorethe Archived Data back to Hard Disk
Y ou may need to copy patient data from the archive mediathat has been deleted from the hard drive. Insert the
Archived Mediaindicated in the disk No. ** and click Ok.

If the patient data is |ocated on separate media, you must first copy the information from each mediato the hard
disk to read the information. Follow instructions that appear on the screen.
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Check the Archive Disk No in the Database List

8-8.Copy Archive Media

Y ou can make a duplicate copy of archived media. This processis only available when the data has not been
deleted from hard disk. If the datais not in the hard disk, copy the data directly in Windows File Copy method.
1.From the menu choose [Archive] > [Maintenance] > [Make the Same Archive Medig].

The dialog window Make the Same Archive Media appears.

2. Input the disk NO to archive again, and click Ok

Under DirectCD software, it is possible to copy the data from CD-R in CD-ROM drive to new empty
CD-Rin CD-Rdrive.

8-9. Restor e Patient Data from Archived Media

When ahard disk crash occurs, patient data may no longer be available on the hard disk. Y ou can restore patient
information from your archive media.

1. After repairing or changing your data drive, insert the last archived media and copy all the datain the archived
mediato your hard disk. You may copy other archived media as needed from older media(small number media).
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9. System Setting

Video input setting, disk setting and figures of hardware connection.
Refer to another “INSTRUCTION MANUAL (Connection Manual)”
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